We have received the final update from our datacenter partner until an RCA and/or additional information is fully released. At this point we will list as Resolved and provide additional information once released.
-------
The datacenter team is continuing to monitor our network for any abnormal or malicious traffic. All recent mitigation configurations will continue to remain in place over the coming weekend; no additional events have been identified over the last 48 hours.
This notice will remain open until we have normalized all network configurations, the specific date and time for traffic normalization to take place over the coming week.
This event continues to remain at the highest priority and visibility with our Executive Network Leadership Team.
Additional updates will be provided for any significant changes in status, or when normalization has been scheduled.
Posted Oct 31, 2022 - 10:43 PDT
Update
True North is continuing to monitor network performance after the DDoS attack on our datacenter facility. We are awaiting an RCA from our partner and will provide once we receive it.
----
The NOC teams are continuing to actively monitor our network for malicious traffic; and while all recent mitigation measures continue to remain in place, traffic has remained stable over the last 24 hours.
Posted Oct 27, 2022 - 09:54 PDT
Monitoring
True North was received word from our Datacenter Partner that the attack has been mitigated at this time. We have verified all customer environments are available and we will continue to monitor for any possible impact in the future.
Posted Oct 25, 2022 - 10:18 PDT
Update
True North has been notified of a reoccuring attack that continues to cause network connectivity issues and latency spikes. We are working closely with our datacenter as they attempt to remediate these issues.
---
The attack traffic that we have seen over the last 48hours has been comprised of multiple attack vectors. We continue to actively implement mitigation measures, but as the attacks have been ongoing malicious traffic would still be present through upstream providers and the internet. That would create increased latency for connectivity to various endpoints.
Posted Oct 25, 2022 - 08:05 PDT
Identified
Datacenter Services appear to be coming back up, and we are monitoring and checking all services for functionality.
Posted Oct 25, 2022 - 05:38 PDT
Investigating
We are currently investigating the issue.
Posted Oct 25, 2022 - 05:10 PDT
Update
True North has received monitoring alerts indicating our affected netblocks have returned to normal operational status. We have verified Citrix connectivity for all previously affected customers as well. At this point we are considering the issue solved and will continue to monitor. We expect additional information on the attack from our datacenter in the coming days as they conduct the required forensics. We once again apologize for any inconvenience this has caused.
Posted Oct 25, 2022 - 03:12 PDT
Update
True North has identified an issue with specific Citrix environments being unable to access Citrix Cloud services. We are working with our datacenter as well as working on alternate routing to bring these environments back online.
Posted Oct 24, 2022 - 20:20 PDT
Update
True North was received a final update from our datacenter for today.. Services are back online and we will continue to monitor for any abnormalities.
-----
Our engineering team is no longer actively making mitigation changes and we are currently seeing the malicious traffic subside. Network traffic has returned to normal patterns and we are still actively monitoring the health of the network.
Posted Oct 24, 2022 - 19:20 PDT
Monitoring
True North has received notification from our datacenter that traffic is starting to return to normal. Our monitors are showing environments returning to normal and we will continue to monitor the situation as it unfolds. We apologize for the inconvenience during this outage.
Posted Oct 24, 2022 - 17:19 PDT
Update
True North has received additional information from the data center facility.
-------
We are still seeing attack traffic present and continue to implement mitigation measures.
Your team would of also received a mass notification from our system making them aware of the overall event.
This event is currently escalated to the highest priority within our network team.
Updates will continue to be provided as they are available.
Posted Oct 24, 2022 - 16:26 PDT
Identified
True North has received the following notification from the data center facility. ---- Please be aware that the Switch Support team is aware of a network event potentially impacting your service.
Our Engineering team has been engaged and has identified malicious traffic targeting various network blocks within AS23005. Mitigation measures are ongoing and we will continue to provide status updates as work continues. ---- True North is working with the data center facility and will update this page as we have more information.
Posted Oct 24, 2022 - 15:21 PDT
Investigating
True North is aware of and tracking an internet connectivity issue at the NWS Las Vegas facility.
Posted Oct 24, 2022 - 14:37 PDT
This incident affected: Ned Web Services Las Vegas Overall Availability (Las Vegas Internet Connectivity, Las Vegas Virtual Machine Availability).